在ubuntu gutsy下编译codeblocks svn版本


本来一直用的是feisty下的一个源:

deb http://lgp203.free.fr/ubuntu/ feisty main

但是自从svn4413版本后就出现问题了,执行codeblocks提示错误:

codeblocks: /usr/lib/libwx_gtk2u_aui-2.8.so.0: version `WXU_2.8.5′ not found (required by codeblocks)

因此,决定自己编译SVN版本,首先下载:

svn co svn://svn.berlios.de/codeblocks/trunk codeblocks

编译前首先要作一些准备工作:

sudo aptitude install debhelper fakeroot wx-common

然后修改codeblocks/debian/control文件,使其中的一些依赖替换为当前gutsy里的版本:

Build-Depends: debhelper, autotools-dev, libc6-dev, libstdc++6-4.1-dev, libwxgtk2.8-dev, wx-common, zip

然后就可以编译了:

cd codeblocks
./bootstrap
dpkg-buildpackage -rfakeroot

编译完成后在上一级目录就生成了对应的deb包。

,

发表回复

您的电子邮箱地址不会被公开。