ubuntu feisty下安装glGo 1.4

官方下载deb包
在ubuntu feisty下,安装glGo还需要以下包:

sudo aptitude install libsdl-image1.2 libsdl-ttf2.0-0 python2.4

然后再安装glgo:

sudo dpkg -i glGo-1.4.deb

这样就已经可以在终端上运行了,若想让其加入到game菜单上,还需要制作一个glgo.desktop文件

sudo nano /usr/share/applications/glgo.desktop

文件内容如下:

[Desktop Entry]
Encoding=UTF-8
Name=glGo
GenericName=glGo Game
Comment=A 3D and 2D Goban, SGF editor, client for IGS-PandaNet and interface for GNU Go.
Exec=glGo
Icon=glgo.png
Terminal=false
Type=Application
Version=1.4
Categories=Application;GTK;GNOME;Game;BoardGame;

拷贝下面这个图像到/usr/share/pixmaps/glgo.png
glgo

linux下的网络围棋软件我觉得就是这个用得最舒服。而且glgo本身也是跨平台的,也有windows和mac平台的版本可以下载。igs-panda

“ubuntu feisty下安装glGo 1.4”的2个回复

  1. I used your exact commands for installing glGo on Gutsy. The program installed OK and launches fine. But it crashes when I click almost anything on the menu. I can use it only if I observe a game and don’t click any options. I get error messages at the terminal like this:
    b5ba4000-b5ba5000 rw-p 00000000 03:42 16Aborted (core dumped)

    Do you have any information on whether anyone can get glGo to work on Gutsy?

发表评论

电子邮件地址不会被公开。 必填项已用*标注